Help Center and Support ticket system not reachable.
Incident Report for Showpad
Resolved
This incident has been resolved.
Posted Sep 09, 2020 - 15:08 CEST
Investigating
The Showpad Help Center and Support system are currently down. We contacted our provider and wait for a resolution.
Our Showpad platform is not affected.
Posted Sep 09, 2020 - 14:09 CEST