Admin App unavailable

Incident Report for Showpad

Resolved

The issue with (what?) is now resolved. We apologize for the trouble and thank you for your patience.
Posted Jun 23, 2025 - 14:10 CEST

Investigating

The Admin App is unavailable
The issue is being investigated internally and will be resolved as soon as possible.
Posted Jun 23, 2025 - 14:00 CEST
This incident affected: Showpad Platform.