Showpad is slow or failing to load
Incident Report for Showpad
Resolved
This incident has been resolved and performance is again at expected levels. We apologise for any inconvenience this might have caused you.
Posted Jul 05, 2023 - 16:00 CEST
Monitoring
A fix has been implemented and we are monitoring results.
Posted Jul 05, 2023 - 15:48 CEST
Identified
Our engineering team is investigating an issue impacting the Showpad platform. Both users and administrators might experience slow loading times or certain areas of the platform being completely impossible to load.
Posted Jul 05, 2023 - 15:44 CEST
This incident affected: Showpad Platform.