Logging into Showpad is slower or failing
Incident Report for Showpad
Resolved
Logging in to Showpad is once again stable and the Platform is accessible.
Posted Oct 23, 2023 - 15:30 CEST
Identified
Our engineering team is investigating an issue impacting the Showpad platform. Both users and administrators might experience slowness when logging in and sometimes the operation might fail with a Server Error.
Please try to refresh if you land on such an error and try to re-authenticate.

We are working on restoring functionality as soon as possible.
Posted Oct 23, 2023 - 15:17 CEST
This incident affected: Showpad Platform.