Showpad is slow or failing to load
Incident Report for Showpad
Resolved
We see platform performance remaining steady and consider the incident fully resolved.

We apologize for any inconvenience this may have caused.
Posted Jan 15, 2024 - 16:59 CET
Update
A fix has been implemented and we see load times drastically improved. We will continue to monitor to ensure full stability.
Posted Jan 15, 2024 - 16:23 CET
Investigating
We have identified and are currently investigating an issue impacting the Showpad platform.
Both Users and Administrators will currently experience slow loading times or certain areas of the platform being completely impossible to load.
Posted Jan 15, 2024 - 15:18 CET
This incident affected: Showpad Platform.