Showpad platform failing to load

Incident Report for Showpad

Resolved

The issue has been resolved and the Showpad platform is back to normal. Reloading the page may be needed if the page contents do not load right away.
Posted Jan 20, 2026 - 18:16 CET

Update

Our engineering team is still investigating the issue.
Posted Jan 20, 2026 - 17:44 CET

Investigating

Our engineering team is investigating an issue impacting the Showpad platform, both for users (the Web App) and administrators (the Admin App).
Posted Jan 20, 2026 - 16:52 CET
This incident affected: Showpad Platform.