File processing - degraded performance

Incident Report for Showpad

Resolved

All files have been re-indexed.
Posted Mar 12, 2026 - 23:47 CET

Update

Root issue has been resolved. We are monitoring the re-indexing of newly uploaded files, but should see these become available while working through indexing the backlog.
Posted Mar 12, 2026 - 21:49 CET

Monitoring

A temporary fix has been implemented. Newly uploaded files will be available in the Library once they are processed.
Posted Mar 12, 2026 - 14:30 CET

Update

We are continuing to work on a fix for this issue.
Posted Mar 12, 2026 - 14:16 CET

Identified

We have identified an issue that is impacting the availability of files in the Library after uploading new files.
Posted Mar 12, 2026 - 14:00 CET
This incident affected: Showpad Content.