Showpad experiencing slowness in navigation and logging in.
Incident Report for Showpad
Resolved
Performance has now fully recovered.

If you are still encountering performance related behaviors, please reach out to our support team at https://help.showpad.com
Posted Apr 05, 2021 - 18:33 CEST
Update
Our team is continuing to monitor the recovery process, however the full recovery is taking longer than initially estimated.

Once fully recovered an additional update will be made.
Posted Apr 05, 2021 - 17:55 CEST
Monitoring
A fix has been implemented by our engineering team. We are continuing to monitor the situation and anticipate the full performance recovering over the next 30mins.

Once fully recovered an additional update will be made.
Posted Apr 05, 2021 - 17:18 CEST
Identified
Showpad is experiencing general slowness when logging in and navigating.

The cause of the issue has been identified by our engineering team and a resolution is presently being investigated.
Posted Apr 05, 2021 - 17:02 CEST
This incident affected: Showpad Coach, Showpad Content, and Showpad Platform.